(Solved) Shows "No data Points" when time is set to shorter than last hour

Hello, with no changes to my graph if I set my timescale to a time shorter than the last hour it wont display any data points but longer than 1 hour display works fine.
Screen shots for extra info:

Works Fine.

Doesn’t Show anything.

As far as I know both of these graphs worked at 15 minutes at one point, I haven’t messed with grafana in a while though so I don’t know what may have changed.

Also Just noticed it doesnt display the entirety of the one hour, it has been running longer than is displaying on the graph at the time of the screen shot, there was a spike which has fallen off the end.

What does Non negative derivative mean?

Its a transformation to turn a running total of Bytes received into a number of Bytes per second.

This is pulling data from an influxDB data source being fed by telegraf

If you remove that (so you will get the running total) does it show data?
[Edit] Also how often is the data stored?

No, removing the derivative transformation doesnt change anything.
Data is being sent by telegraf every 2 seconds to influxDB.

Check what the Query Inspector shows.

Maybe the timezone is improperly configured??

Times appear to be consistent.

So I came back to the issue after dealing with other things for a while and its just working again, I had to reboot my Host due to an unrelated issue and I guess that solved the problem when all my dockers came back online. Guess I have nothing to worry about anymore, thanks for the help though.