Share iframe, unatuthenticated = true but refuses to connect?

Hi!

I’m a bit confused, trying to share a graph as an iframe to include it in my node-red dashboard. I have set anonymous access to true, and it works for browser links, and I can view my Grafana dashboard as Anonymous - however in my node-red dashboard with the iframe pointing to the graph I get a “refused to connect”
image

The node-red instance and Grafana are on the same LAN subnet, just like my computer that can display the graph in a browser. So what is the difference here?

Anonymous viewing works in my browser:
image

1 Like

Ah, solved it: in custom.ini set allow_embedding = true

Just as a request from a user-friendliness-standpoint, it would be cool if features that are disabled in the config would have some sort of notification in the user interface - there is no reason to have the iframe share setting enabled in the user interface if it is disabled in the config. It should be grayed out with a notification that it needs to be enabled by setting allow_embedding = true in the config or something like that. Maybe something for the UX theme to ponder if there is such a team.

# set to true if you want to allow browsers to render Grafana in a <frame>, <iframe>, <embed> or <object>. default is false. allow_embedding = true