How to set up anonymous access?

I am very new to Grafana and I am having trouble setting up anonymous access. I am trying to embed an iframe into a website and the panel says I need to enable anonymous access so users do not have to have a Grafana account.

I know I have to write [auth.anonymous] enabled=true but where do I write this? Any help would be great!

You do that in the config file. What platform are you on? For example on Ubuntu the config file is located at /etc/grafana/grafana.ini.

Hi, after changing grafana.ini, the iframe returns “Access denied to this dashboard”

Did you restart the Grafana server after changing the ini file?

1 Like

How to specify the anonymous user’s username?

1 Like

I have the same problem and I have already restarted the Grafana server and access dashboard via another browser so there is no session but still return “Access denied to this dashboard”

1 Like

same problem, I cannot find a solution…

One thing to check is to make sure the “Viewer” role has privileges assigned for your dashboard. In the .ini file, anonymous users are assigned a role (Viewer by default). So you need to make sure people with the Viewer role can see your dashboard. Might not be your issue, but something to try.

hello. how can the user anonymous write annotations in a dashboard with the org.role=viewers. With the version 7.6 of grafana I could to do it but not with the Version 8.1.5 I can’t do it now. The user anonymous is enable and inside of the same organization with the role viewer. I can watch the dashboard but I can’t write the annotations.