Anonymous dashboard viewing

do you know that semicolon is a comment in ini files? It has tripped a lot of people up. So this line is commented out:

Arggghhhhh! Yep, that was it. Thanks!

Three simple things to check first:

  • did you restart the server after changing the ini file?
  • If you check the Server Settings in Grafana, is auth.anonymous -> enabled set to true:
  • do you know that semicolon is a comment in ini files? It has tripped a lot of people up. So this line is commented out:
[auth.anonymous]
# enable anonymous access
;enabled = true
1 Like

Hello,
Can I change the Home Dashboard for anonymous users?
Because I can’t star the dashboard and change the preferences setting without login.

:wave: Welcome @ncsistdrive! Please start a new thread with your question next time :slight_smile: This is a three years old post where the question asked was another than what you’re asking.

As an admin, go to Configuration > Preferences (it’s on the /org url, e.g. https://grafana.example.org/org ) and you can select either of your favorite dashboards (not sure why it has to be a favorite dashboard of yours, but you can unfavorite it setting it as home if you’d like) to be the global home dashboard.

1 Like