Load denied by X-Frame-Options: <Panel_URL> does not permit framing

Hi all,

i m trying to share a panel via embedding/iframe -
to my own same servers’ http server, but i m getting a

“Load denied by X-Frame-Options: <Panel_URL> does not permit framing.”

This worked on v6.1.6, but not on v6.2.2

I must be missing a setting in grafana.ini - but which one?
Anonymous access is enabled - that s not it.

Thanks in advance,
sebastian

Try with
allow_embedding=true

(https://grafana.com/docs/installation/configuration/#allow-embedding)

1 Like

ok, that was embarrassingly easy - thank you!

(why did i not find this ? … possibly cos it wasnt in the .ini template)

thanks again!

Haha yeah I did wonder whether you’d tried googling, but figured that wouldn’t add much to the conversation :slight_smile:

Based on what you said, I guess what happened is that your original installation of v6.1.6 didn’t include the option in the .ini file (because it wasn’t an option back then), and when you updated to v6.2.2 the original .ini obviously remained in place, so that option never actually popped up.

Thank you for being soft with me … i have accused people of lazy-webbing for less :wink:
In other words, yes, i should have found this and RTFM.

Both installs were from scratch, so it wasnt an upgrading effect.

In my defense, the docs dont mention this, under
https://grafana.com/docs/reference/sharing/
embedding - only “enable anonymous access” - it would be good to mention “allow embedding” there, too.

Hah…yeah it wouldn’t be the first time that the docs are out of date. I suppose since they’re also open-source the nice thing to do would be to submit a PR against https://github.com/grafana/grafana/blob/master/docs/sources/reference/sharing.md

i have submitted a PR - thanks again.

1 Like