Service init failed: Migration failed err: dial tcp 192.12.12.4:54322: connect: connection refused"

Hello friends

I am battling to get pas this error message I am running grafana in docker version 5.4.3 and always get this error not sure what is it that I am missing

#Docker logs

Attaching to grafana
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Starting Grafana” logger=server version=5.4.3 commit=838a282 branch=rhaos-3.11-rhel-7 compiled=2019-11-04T17:22:44+0000
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Config loaded from” logger=settings file=/go/src/github.com/grafana/grafana/conf/defaults.ini
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Config overridden from Environment variable” logger=settings var=“GF_DATABASE_TYPE=postgres”
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Config overridden from Environment variable” logger=settings var=“GF_DATABASE_HOST=postgres:54322”
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Config overridden from Environment variable” logger=settings var=“GF_DATABASE_NAME=grafanaDB”
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Config overridden from Environment variable” logger=settings var=“GF_DATABASE_USER=postgres”
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Config overridden from Environment variable” logger=settings var=“GF_DATABASE_PASSWORD="
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Config overridden from Environment variable” logger=settings var=“GF_SECURITY_ADMIN_USER=postgres”
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Config overridden from Environment variable” logger=settings var="GF_SECURITY_ADMIN_PASSWORD=

grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Config overridden from Environment variable” logger=settings var=“GF_USERS_ALLOW_SIGN_UP=false”
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Path Home” logger=settings path=/go/src/github.com/grafana/grafana
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Path Data” logger=settings path=/go/src/github.com/grafana/grafana/data
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Path Logs” logger=settings path=/go/src/github.com/grafana/grafana/data/log
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Path Plugins” logger=settings path=/go/src/github.com/grafana/grafana/data/plugins
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Path Provisioning” logger=settings path=/go/src/github.com/grafana/grafana/conf/provisioning
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“App mode production” logger=settings
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Initializing HTTPServer” logger=server
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Initializing SqlStore” logger=server
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Connecting to DB” logger=sqlstore dbtype=postgres
grafana | t=2019-11-28T07:26:42+0000 lvl=info msg=“Starting DB migration” logger=migrator
grafana | t=2019-11-28T07:26:42+0000 lvl=eror msg=“Server shutdown” logger=server reason=“Service init failed: Migration failed err: dial tcp 192.12.12.4:54322: connect: connection refused”
grafana exited with code 1
f4832221@fnbuf4832221l:~/prometheus$

#docker-compose file

grafana:
image: registry.access.redhat.com/openshift3/grafana
#image: registry.redhat.io/openshift4/ose-grafana
container_name: grafana

links:

- monitoring

user: "472"
volumes:
 - /home/f483221/prometheus/grafana:/var/log/grafana/
 - /home/f483221/prometheus/grafana:/var/lib/grafana/
 #- /home/f4832221/prometheus/grafana/provisioning/storage
 #- ./grafana/provisioning/storage
 - ./grafana/provisioning:/etc/grafana/grafana.ini
 #- ./grafana/provisioning:/etc/grafana/provisioning
environment:
 - GF_SECURITY_ADMIN_USER=${ADMIN_USER:-postgres}
 - GF_SECURITY_ADMIN_PASSWORD=${ADMIN_PASSWORD:-postgres}
 - GF_USERS_ALLOW_SIGN_UP=false
 - GF_DATABASE_HOST=postgres:54322
 - GF_DATABASE_USER=postgres
 - GF_DATABASE_PASSWORD=postgres
 - GF_DATABASE_TYPE=postgres
 - GF_DATABASE_NAME=grafanaDB
 #- GF_PATHS_DATA='/home/f483221/prometheus/pgdata/var/lib/grafana'
 #- DS_NAME= postgres
 #- DS_TYPE=postgres
 #- DS_URL=http://localhost:3306
 - DS_PASS=postgres
 - DS_USERpostgres
 - DS_DB=grafanaDB
ports:
  - "3000:3000"
networks:
 - monitoring
depends_on:
  - postgres

logging:

driver: “syslog”

options:

syslog-address: “tcp://127.0.0.1:1514”

tag: “grafana”