Samsung TV Browser login issue

Hi,
I have noticed a strange issue on Samsung TV Browser. When I log in to Grafana, after entering valid credentials, there is a standard message “Logged in”, but after that I’m still on login page. I have tried to log in few times with couple of users but result is the same - logging in is successful but I’m stuck at /login page.
I remember that some time ago, month maybe more, it was working. Not sure if it is a Grafana issue or TizenBrowser. Has anyone had this problem?

Grafana version: 6.7.2
TV model: Samsung Q70R
TV firmware: 1356
TizenBrowser version: 2.2.0.0922050
1 Like

We are experiencing exactly the same issue since upgrading to grafana v 6.7.3. Was there any fix found?

Unfortunately I haven’t found any fix or workaround to this. I was experimenting with browser - incognito mode, clearing data etc. but nothing helped.

Update webview,
I was same issue but after update webview from 66 to 80 I can login with Fully Browser.

Can You explain more? Update webview on Tizen? How? And what do You mean with “Fully browser”?

2 Likes

Hello

I have an LG Signage TV.
After updated Grafana to 6.7.2 LG TV stuck on Login page, write login, wrote Logging and not login.
I try to add minipc with android (Odroid N2) but I got same error.
Odroid N2 used webview v66 but got same error.ű After Android Webview updated to v81 login start working.
No other patch needed.
I hope developers working on this problem, but maybe there is security issue.

I have updated to Grafana v 7.0.0 and this issue is still there. Any workarounds or fixes in the pipeline?

As updates for Tizen OS or Browser are unavailable, best option is to enable Grafana AUTH Proxy options, and to enable it only for requests from IPs from your TVs.
after editing grafana.ini to enable it, create something like this in your nginx configuration:

Blockquote
set $UD “”;
if ($remote_addr = 1.1.1.1){
set $UD user;
}
if ($http_user_agent ~* “.Tizen.”){
set UD "{UD}name";
}

and in location block
just add header with $UD variable (username).

more info can be found

Hmmm, interesting… I have done some experiments and for me Grafana works on Tizen Browser ONLY when authentication is set to anonymous and there is no authentication in webserver. Otherwise I see this (attached image).
Maybe this Tizen Browser is simply too stupid to handle this way of auth?

It looks like it is kinda stupid and outdated.
Use Nginx and auth proxy to enable standard logging for external users and this kind of config mentioned above for only tizen agents. Also make sure you whitelist only certain IPs on both nginx and grafana.ini config, to ensure maximum security.