Push message mismatch for high rate telegraf input

Hi,
I use the OPC input of Telegraf with the Websocket output at a rate of 100 ms and feed that into Grafana via Live Measurements (similar to what is described in Stream metrics from Telegraf to Grafana | Grafana Labs ).
However, after a while (usually ~2 minutes), I am constantly getting exceptions from Grafana with the message “Uncaught Error: push message mismatch. Expected: 15, received: 183 (labels=true)” and the live view stops. The CPU metric from Telegraf that I run in parallel runs without any interruptions.

Any idea what could be the cause of this exception?

Thanks,
Florian

I am also seeing this message in the Websockets capture, maybe this full matrix with the many nulls has something to do with it:

0: ["host=localhost, id=ns=2;i=6019", "host=localhost, id=ns=2;i=6020",…]
1: [1712615337602, 1712615337602, 1712615337602, 1712615337602, 1712615337602, 1712615337602,…]
2: [0, null, null, null, null, null, null, null, null, null, null, null, null]
3: ["OK (0x0)", "OK (0x0)", "OK (0x0)", "OK (0x0)", "OK (0x0)", "OK (0x0)", "OK (0x0)", "OK (0x0)",…]
4: [null, 0, null, null, null, null, null, null, null, null, null, null, null]
5: [null, null, 0, null, null, null, null, null, null, null, null, null, null]
6: [null, null, null, 0, null, null, null, null, null, null, null, null, null]
7: [null, null, null, null, 0, null, null, null, null, null, null, null, null]
8: [null, null, null, null, null, 46.11357116699219, null, null, null, null, null, null, null]
9: [null, null, null, null, null, null, 44.693050384521484, null, null, null, null, null, null]
10: [null, null, null, null, null, null, null, 1050, null, null, null, null, null]
11: [null, null, null, null, null, null, null, null, 62, null, null, null, null]
12: [null, null, null, null, null, null, null, null, null, 100.44715118408203, null, null, null]
13: [null, null, null, null, null, null, null, null, null, null, 33.551246643066406, null, null]
14: [null, null, null, null, null, null, null, null, null, null, null, 25.07175064086914, null]
15: [null, null, null, null, null, null, null, null, null, null, null, null, 3.363116314379561e-44]

Hi,

We are experiencing the same things, high speed data over telegraf into Grafana Live. The errors are indeed occuring on the client side and we also have a lot of null values.

Did you find a solution yet?

One of the options I see is streaming to Grafana over http instead of ws.

Thanks,
Daan