PRTG + Graftana

Hi there

Trying to connect to PRTG as a datasource from Graftana … Every combination I try seems to fail - has anyone set it up hooking into PRTG before ? Im following this guide, and doing as it shows (tho I run over https) , however it cant seem to connect in, using either an admin account in PRTG or Read only user. Have tried a few combinations but no luck. Anyone managed to successfully get it to work? Or is there a debug log I could try read somewhere?

Thanks

Do you get any specific connection error? Is PRTG data source plugin you installed?

I have only tested locally over http but here is what my settings look like:

  • You should be using proxy mode
  • You can check for an error in the Chrome console
  • You can check for an error in the Grafana logs on the server
  • If you are using a self-signed certificate then you should select the “Skip TLS Verification (Insecure)” option

I am having the same problem and just wrote a post here about what I am experiencing, same as you, however I found out in the settings via the CLI how to enable more robust Grafana logging. It returned an odd message but no error per se. Hopefully the community will have some ideas and is active.

Maybe you could paste in the “odd message” here? Hard to help without any details.

Mr Lee I would completely agree, its hard to fix or correct anything if there are not any details. You can imagine my exasperation and anxiety when a red bar with an exclamation point appeared with nothing else.

There is nothing to paste to your point because grafana does not explain what went wrong. Sexy program for sure, needing some stability and maturity also something it needs for sure.

The PRTG data source is an external plugin and it is the first version so maybe it is not up to the standard of core Grafana yet. (I am sure you could help out by submitting a PR improving the error handling for the test data source function or at least an issue reporting the problem - the repo is here).

It is however definitely possible to get the error. I presume you are getting an error on the data source page when clicking on the Save and Test button. Open the Chrome dev tools (or for whichever browser you are using) and check the console:

image

Are you using the Passhash or the actual user password. The user password will not work. You need to use the PassHash that is stored in PRTG.