Playlist keeps asking to save changes


After Friday my Grafana Playlist on Rasberian Stretch is constantly asking to save changed to each slide it goes to. Anyone seen this before?

Did you by any chance upgrade Grafana? The dashboards might change when you upgrade and in that case that happens on load and you have to save them to get the new version of the dashboard. If that is the case, just open the dashboard that asks to be saved and save it and it should stop complaining.

I tried that with no luck. I opened each dashboard and made sure it had been saved. I even ran through the playlist and hit save each time it asked, when it got back to the first dashboard it again asked me to save.

I think it has something to do with the latest Raspbian Stretch, I have other Pi’s running Raspbian normal and it doesn’t get this issue. And my MBP doens’t have this issue either.

Could you open an issue about this on our issue tracker? Hard to say exactly what it is, but it could be a bug.

Are you able to save real changes?

Yes I can save all types of changes.

Maybe you’ve upgraded Grafana and Grafana migrates dashboards to a new schemaVersion?

I have this exact same issue with multiple dashboards and it doesn’t always seem to be the same ones. I have saved them all multiple times and each time the playlist prompts me as well. It seems that it is only impacting dashboards created prior to any upgrades. Would really like to make it go away… :slight_smile:

I have same issue with all the dashboards. It started recently after I upgraded grafana to v6.4.3 from v6.1.4.
By the way I’m using Grafana Docker image.

I have tried saving dashboards over prompt but it still asking me to save changes on exit.


Have what I presume is the same issue, as described here.

I ended up saving all dashboards. I have no issue afterwards.
I don’t know why it didn’t work earlier as I reported. I restarted Grafana by recreating container though.