Panel x axis labels time format

  • What Grafana version and what operating system are you using?
    Grafana v10.2.0

  • What are you trying to achieve?
    Time format for the x axis labels

  • How are you trying to achieve it?
    Defined Time override

  • What happened?
    For tooltips it works, for the x axis labels no change

  • What did you expect to happen?
    time format for the x axis labels as configured with the override

  • Can you copy/paste the configuration(s) that you are having problems with?

{
  "datasource": {
    "type": "tribe-29-checkmk-datasource",
    "uid": "b46ddbd4-a196-40b7-8c51-12aac6012194"
  },
  "description": "",
  "fieldConfig": {
    "defaults": {
      "custom": {
        "drawStyle": "line",
        "lineInterpolation": "smooth",
        "barAlignment": -1,
        "lineWidth": 3,
        "fillOpacity": 100,
        "gradientMode": "scheme",
        "spanNulls": false,
        "insertNulls": false,
        "showPoints": "auto",
        "pointSize": 4,
        "stacking": {
          "mode": "none",
          "group": "A"
        },
        "axisPlacement": "auto",
        "axisLabel": "",
        "axisColorMode": "text",
        "axisBorderShow": false,
        "scaleDistribution": {
          "type": "linear"
        },
        "axisCenteredZero": false,
        "hideFrom": {
          "tooltip": false,
          "viz": false,
          "legend": false
        },
        "thresholdsStyle": {
          "mode": "off"
        },
        "axisSoftMin": 0,
        "lineStyle": {
          "fill": "solid"
        }
      },
      "color": {
        "mode": "thresholds",
        "fixedColor": "light-green",
        "seriesBy": "last"
      },
      "mappings": [],
      "thresholds": {
        "mode": "absolute",
        "steps": [
          {
            "color": "#224488",
            "value": null
          },
          {
            "color": "#660000",
            "value": 47.6
          }
        ]
      },
      "displayName": "Temperature Outside",
      "unit": "celsius"
    },
    "overrides": [
      {
        "matcher": {
          "id": "byName",
          "options": "Temperature"
        },
        "properties": [
          {
            "id": "color",
            "value": {
              "fixedColor": "green",
              "mode": "thresholds",
              "seriesBy": "last"
            }
          }
        ]
      },
      {
        "matcher": {
          "id": "byName",
          "options": "Time"
        },
        "properties": [
          {
            "id": "unit",
            "value": "dateTimeAsIsoNoDateIfToday"
          }
        ]
      }
    ]
  },
  "gridPos": {
    "h": 9,
    "w": 12,
    "x": 0,
    "y": 0
  },
  "hideTimeOverride": true,
  "id": 8,
  "options": {
    "tooltip": {
      "mode": "single",
      "sort": "none"
    },
    "legend": {
      "showLegend": true,
      "displayMode": "table",
      "placement": "bottom",
      "calcs": [
        "min",
        "mean",
        "max",
        "lastNotNull"
      ]
    }
  },
  "targets": [
    {
      "datasource": {
        "type": "tribe-29-checkmk-datasource",
        "uid": "b46ddbd4-a196-40b7-8c51-12aac6012194"
      },
      "refId": "A",
      "requestSpec": {
        "aggregation": "off",
        "graph": "METRIC_Temperature",
        "graph_type": "predefined_graph",
        "host_name": "KENIG",
        "service": "Temperature Outside",
        "site": "monitoring"
      }
    }
  ],
  "timeFrom": "now-14d",
  "transformations": [],
  "type": "timeseries"
}

Please advise.

UPDATE

The date and time formats are taken from the grafana.ini file (Linux), however, it is not enough to reload the dashboard, you need to reload the page in the browser (after restarting the Grafana server).