Noob help please

So i’m new to grafana and I have been trying to read docs but need a little direction if someone would be so kind.

So I have the latest prometheus installed with node exporter(s) collecting data. That all works fine. Plugged in alertmanager, installed latest grafana everything is talking to each other and seems to be working.

So I’m trying to get some dashboards up and I’ve gone and tried to import some dashboards. Some work off grafana’s site right off without tweaking. But there’s one in particular I wanted to get working.

That has 13K downloads and no one else seems to be having issues.
But I import the json i download and I get a blank screen. My variable pickers are correct but I get nothing rendered below that.
If I try to view the json it’s blank. I get this same behavior if I use the number to import the dashboard. One thing I noticed is I tried to open the downloaded JSON file and the cut and paste the contents and import the dashboard that way. When I do that I get the following error.
“Unexpected token u in JSON at position 0”
but I get no errors when importing the file or using the number off grafana’s site to import it, i just get no graphs just some variable pickers.

I have looked in /var/log/grafana/grafana.log that has no useful info in it. I can’t do a query inspector because I don’t really get a row with a panel with a query to inspect.

Anyone else hit an issue like this? and what’s the best way to troubleshoot?

Ok. please disregard. i was not on the latest grafana like I thought, upgrading grafana resolved the issue. :expressionless:

1 Like

Good to know - thought it might have been a bug in Grafana