Missing data when exporting csv

I’m not really sure if this is a configuration issue, but I suspect so…
When i export csv data, Grafana is decimating my data.
Grafana reads data from an Influxdb database, and it contains data with 1s interval.
And I can see from the graphs in grafana that there are data for every second.
But when I try to export data from a longer period of time it decimates the data.
For example, if I try to export data for 7 days, i get data with 10 minutes interval only (see attached pic).

And if I try to export data for 6h, I get the data in 15s intervals.
I suspect that there is a setting somwhere that limits the maximum number of rows in the csv-file, but I can’t find where…

I might add that I have tried upgrading grafana (from 6.4.3 to 8.5.2) with the exact same result.
We also have other computers at work where we are using grafana/influxdb in the same way, and the csv-export works fine on them.
So this issue is on one computer only, and I fail to see what is different from the others…
So I would really appreciate some help.


Here you can see that the time interval is 1s (as it should be) when I export csv-data for a smaller time window (5 min in this case).

I have now realized that it isn’t Grafana that causes the decimation of data.
Grafana doesn’t get all the data from InfluxDB, when it tries to fetch large quantities of data.
So it’s probably some InfluxDB setting that is causing this, but I havent’ been able to figure out how to fix it…