MariaDB DATETIME with Grafana time offset - time different 1 hour

I have some sensors. When I look into my database with phpmyadmin at my QNAP - the values are ok.
When I use the grafana Dashboard, I use Germany UTC+1 time zone. The values at datetime differs to 1 hour.

What can I do? Any help are welcome.



1 Like


Welcome Heinz.

It sounds like you have everything correctly configured. It may be a bit of a hack, but you could put a 1 hour (or -1h) value into the field Time shift under Query options…


The graph is changeing. But when I do a mouse over the values, than it show me the value as before with 1 hour different to the value in the database.

Thanks for the help

I do not know much about MariaDB, but if it behaves like MySQL, maybe this is the problem (and the solution)?

Thank you for your help.
I will check this. But for me, it looks like a grafana bug.
So for now, I have to look how to convert this with my phpmyadmin. I am not familiar with sql.
And the next step is to change all scripts, that put my values into the data base. So I have to change the format.
But I will come back to tell the result.


Hi Heinz,

I have the exactly same issue with mariaDB and Grafana.

I was playing around with session timezone settings for the data source and with timezone settings for the dashborard(s) I created but could not find a solution for the offset problem. I’m pretty sure timezones on my NAS running mariaDB and on my Pi running Grafana are configured properly (CET).

Have you found a solution in the meantime?

Thank you - Simon