Datetime being offset by 1 hour

I’m running the latest version of Grafana on a windows server. Its being used to display data pulled from an MSSql db, which is on the same network, same timezone. Client machines, i.e the browsers, are on the same network, same timezone.

The problem I’ve got is that datetimes are being offset by +1 hour in the TimeSeries panel.
This is the only panel I’m using which uses data with times.

All machines involved are in the same timezone and I’ve checked that the clocks are all the same with the same time and region.

Using the sql management studio I can query the stored procedure and I get times which are correct.
I’ve tried forcing the datetime to UTC using “at time zone ‘UTC’”- no effect
I’ve tried forcing the datetime to CET using “at time zone ‘CET’”- no effect
I’ve tried converting the datetime to unixtime - no effect, though the times displayed in grafana were the same, so my conversion to unixtime seems to have been correct.

No matter what I do, the timeseries panel is modifying the times by 1 hour.

If I view the data in tableview from the timeseries panel designer, the times are 1 hour offset.

I’m in CET timezone, so thats GMT+1.

values are being written into the DB in local time. I’m not sure how to query mssql to work view the ‘raw’ datetime, so it could be that managment studio is offsetting the times to compensate for local time, but I don’t think it does.

I assume that this is a common problem, but I can’t find much on the forums.
The only option in the server ini file which seems to affect the time is this
default_timezone = browser
and I’ve tried several options but the time is always the same, offset by +1 hours.

Any suggestions as to what I can look at to diagnose this. I don’t want to just fudge the query to add an hour.