JSON API data source unable to graph data from thingspeak

Good Day,

I am having trouble displaying data from thingspeak via the JSON API datasource plugin.

I am using the following URL to get a the data as JSON from thingspeak:
https://api.thingspeak.com/channels/1103934/fields/1.json?days=7

As query I use the JSON paths
β€œ.feeds[*].field1" and ".feeds[*].created_at”
successfully generating a table.

Unfortunately I do not manage to display the imported data as graph. I suspect they are not recognized as time series.

Help is very much appreciated!

1 Like

Hi,
I’m having a similar problem. did you ever get a solution?

Same problem here, had to apply transformation and override unit to get it into datetime format though.
Is that the problem?

I am completely new to grafana and I have the same problem.
Can you please tell me how to apply this transformation?
Thanks in advance.

My problem was because the numeric values had quotes around them.
I removed the quotes and it worked :slightly_smiling_face:

Thanks for help.
I used the infinity plugin, in basic mode and it worked just fine.

1 Like

It turned out that this was my problem too. The values with quotes were interpreted as string. I solved it for now by recompiling the plugin on a raspberry pi with less strict value type checks.

With the recent version of json api, you will have ability to specify fields as time fields.

BTW, as @patz said here is a working example from grafana infinity datasource for the url @gregorschulte shared.

Detailed example is available here

Hello,
Thank you very much it does work for me now, but I have one problem, the maximum return is 100 raws and I have about 1200 rows; How possible to make Json API return more than 100?