Issue with Bar Gauge (One column always with no fill)

I am trying to represent the number of matches within an integer parameter.


As you can see, the first bar (if i comment any of the columns in my athena query, the no fill bar is random) doesnt have enough fill. 6 should be at least half of the next one right?

Any idea how to solve this?

Data:

in the panel editor, is the max setting set to auto? Have you tried giving it a hard-coded min and max?