Install on Ubuntu 18.04 LTS

Just attempted installing Grafana on a new install of Ubuntu 18.04 with the followign commands:

sudo apt-get install -y adduser libfontconfig
sudo dpkg -i grafana_5.1.0_amd64.deb

I cannot start the service. I get the following error:

me@nuc03:~$ sudo service grafana-server start
Failed to start grafana-server.service: Unit grafana-server.service not found.

I assume something changed in Ubuntu 18.04 and Grafana is unable to put its init.d files in the right locations?? Any ideas on how to fix? I’d love to get this working on the latest UBuntu, but I will downgrade to 16.04 if I have to.


First time I see this reported. Check the Grafana server log. Can you please provide more logs/information?


I am running Grafana on 18.04 Server.
Here is what I did.
After dpkg -i grafana_5.1.0_amd64.deb

Run apt update
then apt install grafana
then try starting the service with Systemd systemctl start grafana-server.service

Hope that helps!

I just tried this. It didn’t work. Did you have to enable additional repos?

me@nuc03:~ sudo apt update Get:1 bionic-security InRelease [69.9 kB] Hit:2 bionic InRelease Get:3 bionic-updates InRelease [65.4 kB] Hit:4 bionic-backports InRelease Fetched 135 kB in 2s (84.2 kB/s) Reading package lists... Done Building dependency tree Reading state information... Done All packages are up to date. me@nuc03:~ sudo apt install grafana
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package grafana

The service file wasn’t properly put into place and I cannot start the grafana service. There are no logs to look at…

Sorry, I failed to mention. Try adding the APT Repository from the Grafana install instructions.
Then use apt to update and install.
Installing on Debian / Ubuntu

I was thinking about my MySQL installation when I mentioned dpkg -i, but I typically use the repo when installing Grafana so I’ll get the updates when released.

Using the repo install worked. Not sure why dpkg -i doesn’t work on 18.04.

Good to know that worked for you.