How to secure Windows Server 2016 Grafana with HTTPS, port 443

Hello all, I’m trying to implement HTTPS communication. I converted my .p7b bundle to .crt file. Also I have the private key file which has .pem extension. I’m providing my defaults.ini and sample.ini file’s screenshots below.

Default.ini file:

sample.ini file:

certificate paths:

C:\Program Files\GrafanaLabs\grafana\grafana.crt
C:\Program Files\GrafanaLabs\grafana\grafana_key.pem

Error ( still can not connect via port 443)

Do you have any suggestions guys?


What does your log file say about this issue? btw it can be any port, does not have to be 443
Also grafana uses default.ini not sample. so you need to make your changes to the default.ini

So, should I edit the default.ini file without changing its name?

I edited the parts that I pointed in default.ini file.

nice. now restart the server and point your browser to https://localhot:8080

I’m getting HTTP ERROR 400 :frowning:

Are there any other things that should I do?

you could show us what your log file says about this?
Also did you

  1. did you edit default.ini
  2. restart the grafana server in services
  3. pointed your browser to https://localhot:8080

Yes, I did 3 of them. Here is my log file. It says lots of things :smiley:

I just create crt and key using openssl

openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout grafana.key -out grafana.crt

copied them over to grafana folder, change my default.ini to point to the them.
restarted my grafana server service
pointed my browser to https:\localhost:8080

works on my PC :joy:

Did you install enterprise version or OSS

I’m using OSS version.

Could it be related to the extension of my private key file? My cert file ends with .crt and key ends with .pem.

1 Like

Did you make any changes to the dashboard or windows settings?

nope. those have nothing to do with https
I think the .pem might be an issue. for testing purposes create them using openssl I pointed above and use those instead.

I’m gonna try that ASAP. Thank you. I will inform you about the result.

1 Like

I tried it but still not working. Btw I’m in a enterprise network. Could this be the problem?

ah, that might be it. but how are you accessing the grafana endpoint and from what pc/laptop?

what happens when you access it locally from within the server itself

I’m accesing from the virtual server which grafana installed. I can connect via port 443 but http protocol. When I change the protocol to https I’m getting

This page isn’t working

If the problem continues, contact the site owner.


So, I think there is page in the background but I can not connect.

works with port 443 too. but not working with https protocol

so your cert must be clashing with domain cert I suspect. but this is not really a grafana issue but more of networking issue you should reach to your Domain Admin to.

1 Like