How to remove/disable gradient in background color

Grafana 7.0.5.

I have a panel with Table visualization and I added Cell display mode override to set the Color background for a column.

The override is applied just fine, but the color is added with gradient, though I only chose a plain color from the color picker, and there was no option for gradient there:

color-picker

Nevertheless, the column has a gradient applied:

Here’s what I see in the page source:

<div class="css-vvkkwd">FAIL</div>
.css-vvkkwd {
	text-overflow: ellipsis;
	white-space: nowrap;
	overflow: hidden;
	background: rgba(0, 0, 0, 0) linear-gradient(120deg, rgb(239, 25, 32), rgb(242, 73, 92)) repeat scroll 0% 0%;
	color: white;
	height: 33px;
	padding: 6px;
}

How can I disable this gradient, and is there a way to set “no gradient” option to apply by default for all new color overrides (or colors in general)?

I also have another panel with Table visualization which I created when I was on Grafana 6.x, and it also has a color override for background color, and I used the same color picker and picked the same color, and there it is applied without gradient.

5 Likes

@retifrav , Did you find a solution to this?

Unfortunately, no.
I was hoping that it might be some accidental change/bug/regression, but sadly there is still no reply from developers.

We have the same issue - we are using colours as defined by ISO (google “iso vibration color definition”). Having an applied gradient that can’t be turned off is not useful and having the colours of satisfactory (yellow) and unsatisfactory (orange) blending into each other is less than ideal!