How to remove "count" from showing up as part of the legend

  • What Grafana version and what operating system are you using?

    • 9.1.1
  • What are you trying to achieve?

    • Display results in legend
  • How are you trying to achieve it?

    • Now sure how to say this without sounding snarky, but, following the normal process to build a time series panel that displays results in the legend
  • What happened?

    • The results show but it also displays count before each result, see screenshot. This only happened after our upgrade to Grafana 9
  • What did you expect to happen?

    • The legend should not display count as part of the result.
  • Can you copy/paste the configuration(s) that you are having problems with?

    • Cannot due to sensitive data.
  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.

    • No erros
  • Did you follow any online instructions? If so, what is the URL?

    • No instructions followed, just worked on the panel like I normally do for time series data.

For additional context, this is based off a postgres query that when tested in DataGrip or pgAdmin does not display the results with count as part of them, this is only happening in Grafana.

I did see a possible solution, but it requires manually adjusting each panel and that is not an efficient way to do this…

Under the All tab > Standard Options > Display Name type ${__field.labels.__values}