How to remove "count_" from the legend of a graph panel (Grafana + Azure database)

  • What Grafana version are you using?
    Grafana v8.1.1

  • What are you trying to achieve?
    I have created a pie chart that shows the number of errors that have occurred in the last 24h:
    image

I would like to hide the “count_” that appears in the legend. How can I do this?

  • How are you trying to achieve it?
    I’ve tried to solve my problem using Overrides to no avail. Before I explain what I’ve done, keep in mind that there isn’t a limited number of error messages that might appear in my pie chart and I have no way of predicting which errors are going to appear on a given day. With that said, here’s what I’ve done:
  1. Navigated to the Overrides tab
  2. Selected Fields_with_name:“count_ (base field name)” to make my override applicable to any error message that might appear
  3. Selected Standard_option_>Display_name and typed “.” (full stop). I expected the "count" to be replaced with an unobtrusive “.”, thereby producing the legend: “. HBBTV_BC_ERROR”. Instead, the entire legend got set to “.” . I kind of need the error message to show…

Any ideas how I can get rid of “count_” only?

Found a solution:

Under the All tab > Standard Options > Display Name type “${__field.labels.__values}”

This topic was automatically closed after 365 days. New replies are no longer allowed.