How to manually install the grafana-clock plugin

I’m trying to install the clock plugin on a non internet-connected system. I’ve got the zip file in /var/tmp;
how do I install it? I tried unzipping it into /var/lib/grafana/plugins, but no joy.

tried with the cli, and instead of http://… I used file:///kvar/tmp/grafana-clock…
No joy - it doesn’t underatand the file: protocol.

In both cases, I restarted grafana-server.

This is grafana 5 (latest version), on rhel 6.7

Thanks!
Graham

Hi,

Please see installing plugins manually documentation.

Marcus

I did - that’s where I got the idea of using a local url. Sorry, but it’s not especially clear (to me at least). I unzipped the file into the plugins directory and restarted Grafana-server each time - but no joy.
Thanks

Permissions. Nitwit! (me)
Thanks
Graham

2 Likes

hi @grahamnicholls

Cant find my grafana folder under /var/lib/. This being a office machine we installed it on a desktop for trial purpose, so does the default location of the plugin folder change?

and I am facing the same issue. Can you please elaborate on what do you mean by permissions issue?

Thanks

I’m sorry, but I simply don’t remember. Assuming you’re running Linux, try
$ sudo find / -iname “grafana” -print
perhaps?

I suspect that I’d made the directory as root and not changed the ownership to the grafana user. Sorry, if by “desktop” you mean Windows, I can’t help.

Graham

Thanks Graham.

But I am not on the sudoers list to use that command. But, I think I have 2 folders where plugins are present

  1. …/grafana/data/plugins/ and this is what is listed when we try and start the Grafana like below
INFO[02-04|13:54:37] Starting Grafana                         logger=server version=5.4.3 commit=6539180 branch=HEAD compiled=2019-01-14T09:26:26-0500
INFO[02-04|13:54:37] Config loaded from                       logger=settings file=...grafana/grafana/grafana-5.4.3/conf/defaults.ini
INFO[02-04|13:54:37] Config loaded from                       logger=settings file=..../grafana/grafana/grafana-5.4.3/conf/custom.ini
INFO[02-04|13:54:37] Path Home                                logger=settings path=...../grafana/grafana/grafana-5.4.3
INFO[02-04|13:54:37] Path Data                                logger=settings path=/..../grafana/grafana/grafana-5.4.3/data
INFO[02-04|13:54:37] Path Logs                                logger=settings path=/...../grafana/grafana/grafana-5.4.3/data/log
INFO[02-04|13:54:37] Path Plugins                             logger=settings path=/....../grafana/grafana/grafana-5.4.3/data/plugins
INFO[02-04|13:54:37] Path Provisioning                        logger=settings path=/....../grafana/grafana/grafana-5.4.3/conf/provisioning

So I am assuming ..../grafana/data/plugins/ is the plugin directory. So i unzipped the downloaded plugin zip here

But at the same time i also found that there is another folder where I can see all the installed default plugins and that is ..../grafana-5.4.3/public/app/plugins/datasource/ like in the below picture:
datasources

So, assuming this is the place where all the plugins are present, I tried to unzip here as well but even that does not work

So I am at a place where i am not sure what else can I try

Please look at my other doubt here: Druid plugin manual installation

leads are very much appreciatedd
Thanks

I think, I got the plugin folder

in the conf file it says that the plugin folder is:

...../data/plugins/

cat /....../grafana/grafana/grafana-5.4.3/conf/defaults.ini | grep -i plugin
# Directory where grafana will automatically scan and look for plugins
plugins = data/plugins
# for new versions (grafana itself and plugins), check is used
# in some UI views to notify that grafana or plugin update exists

So the plugin has to be unzipped to this folder ..../data/plugins/, so the next issue is this:

please help
Thanks