Problem by installing a Grafana plugin

Sorry for using google translator but my english is really not good enough anymore. I just wanted to install this plugin via the terminal with this command: grafana-cli plugins install grafana-clock-panel. But then I get this message:
Error: ✗ pluginsDir (/var/lib/grafana/plugins) is not a writable directory
I have no idea how to get rid of this, since I’m not very familiar with terminal commands.
I had already installed Grafana and then suddenly Grafana was no longer accessible. Then I did something where I had to confirm the authentication with my password.
Now I need your help to make it work smoothly again.
It would be great if you would help me here.

Thank you in advance.
Greetings Andy

1 Like

Okay fine?

Can you tell me what exactly happened that grafana doesn’t work? He doesn’t access it anymore, the graphics don’t appear, what exactly happens?

Also let me know what you want to use this plugin for, maybe there’s an equal or even better one I can recommend.

Greetings Dennis!

Hello Dennis,
Thank you for your help. My Grafana works. Now I just wanted to add the plugin for the clock and I got this error message. I might want to include the clock in one or the other diagram.
I suspect that installing another plugin would not have worked either.
But since you’re offering me your help, I have an additional question: How can I get the values to be displayed in the diagram itself, e.g. from the temperature. I haven’t managed to do that yet.

Greetings Andy

Hi!

Okay, what version of your grafana?

I ran the same command on a Centos8 and it worked fine in version 7.5.

Plugin clock only shows the time.

To show temperature has the dash gauge, stats, and others.

To receive the values ​​you need an integration data source with a tool where the temperature data is, for example, a zabbix.

Right after the precise configuration as metrics in grafana, it’s in the tool you use to adjust the temperature

Greetings Dennis

My version of Grafana is 8.4.5
I just searched for the term clock in the plugins directly via the Grafana interface and was able to install this plugin directly. But where can I find the plugin now to integrate it somewhere?