How to cleanly uninstall grafana

Have tried installing grafana on a brand new Red Hat Linux v7.1 as per the documentation.
After getting round most of the gotcha’s not documented…
However I have been unable to connect to the web front end.
There appears to be no information on what this needs to make it work.
All indications are it is working but I only get "The connection has timed out"
Disabled firewall with no joy.
ABsolutely nothing in the logs, tried enabling debug for logs, nothing.
So after wasting several hours I just want to know how to cleanly uninstall it.
Hopefully someone has done this before?

Looks like a networking issue with your Redhat server, after grafana server starts it should be available via web browser on port 3000 (unless you changes port) if this does not work check your firewall.

Uninstaling is just like any rpm package

Hi Torkel,

I tried disabling the firewall completely, it made no difference.

Cool, thx, just wasn’t sure if it left directories/files behind that needed cleaning up.


Bill Wilson | VMware & Storage Design Lead | ITS Strategy & Design | The University of Auckland
(ddi) +64 9 923 9934 | (mob) +64 21 370 979 |(email)

It sounds very strange that there is nothing in the Grafana server logs if it didn’t start up properly. If you haven’t given up totally, you could post a screenshot of the Grafana server log after startup and we might be able to help.

Im thinking of giving up on Grafana also as its unusable. Devs should rethink their strategy.

Care to expand on that? What makes it unusable?


Its main goal is to visualize (make it easy to visualize any source). Its hard as hell. Nothing is working (despite communication grafana<>monitored source) being success.

My topic on why its unusable

We are aware that Grafana can be difficult for first time users and we are happy to help you get going. (One of the aims of the next release is to introduce usability improvements to make the first few steps easier for new users).