How to change the grafana OAuth client authentication method to "NONE"

hi ,
I got following error when I using oauth ,is there any method to change the client authentication method? thanks

error message:
401 Unauthorized\nResponse: {“error”:“invalid_client”,“error_description”:“Client authentication failed (e.g., unknown client, no client authentication included, or unsupported authentication method)”,“error_hint”:“The OAuth 2.0 Client supports client authentication method \“none\”, but method \“client_secret_post\” was requested. You must configure the OAuth 2.0 client’s \“token_endpoint_auth_method\” value to accept \“client_secret_post\”.”,“status_code”:401}"

That will be bad idea. Are you sure that used client is configured correctly?
Blind guess: client is public, so you should to enable pkce in the Grafana. You didn’t provide reproducible example, so it is only my humble guess and there can be many more problems.