How to add MSSQL Data Source with instance name?

Hello,

could anyone help me on how to add MSSQL server data source using instance name?

I can login to following server using SQL Server Management Studio: “svkt1066\smp”, where instance name is “smp”.

Grafana doesn’t allow me to do this as it is constantly correcting single-backslash to double-backslash. Could this maybe be an issue? Or is there anything else? Does anyone use an instance name when connecting to MSSQL DB?

Grafana version: v7.0.1 (ef5b586d7d) / Open Source

1 Like

grafana version 7.1.3 work with notation IP\INSTANCE correctly. Above versions refused to connect.

then, how to setting grafana datasource to sqlserver\instance ?

having this issue as well; I cannot add a named instance of a database

figured this out by downgrading to a previous version of grafana; 6.7 I believe.

Connect your instance via tcp port: sqlserver:port

To figure out your tcp port execute following sql in master database
xp_readerrorlog 0, 1, N'Server is listening on'