Hover tooltip (All series) not working

Hi.

I have one graph with 2 queries. I’m trying to configure the tooltip option, but when I set to “All Series” the tooltip does not appear. But when I set to “Single” it works normally. What I need to configure, to both tooltip appear and work together? Im using Grafana 7.

Some screenshots:

Screenshot_3

1 Like

I am facing similar issue. Not sure if it is a bug.

Also facing this issue using postgres plugin. When Hover tooltip is set to All series the values in the graph are not updated and seem to freeze at some initial value while hovering through the graph.

Using Grafana 7.2.0 with postgres 11
Example:

I just ran up against the same thing using the SQLite plugin. I had set up my time-series SQL query to order by time DESC, which was graphing correctly. I tried switching it to order ascending and the hover tooltip started working! Who would have thought.

Thanks, I had the same issue, ordering in ascending helped me :wink:

Get it, I have faced this similar issue. I am trying to change return type of fields, e.g:
CAST(capacity AS UNSIGNED INTEGER) AS capacity
And then it be effected, look at grafana vales of tooltips. Nice !!

Hi,

tango0o,
I have the same problem.
There is two queries, (originally: )

SELECT last(“value”) FROM “home-sensors-temp-1” WHERE $timeFilter GROUP BY time($__interval) fill(none)

and

SELECT last(“value”) FROM “home-sensors-humi-1” WHERE $timeFilter GROUP BY time($__interval) fill(none)

and I tried to use CAST, but there is no function like this,

SELECT CAST(value AS UNSIGNED INTEGER) AS value FROM “home-sensors-humi-1” WHERE $timeFilter GROUP BY time($__interval) fill(none)

error: “undefined function cast()”

What did I wrong? Can somebody help me, please?

hi, @ipss

cast as inner funcation of general database, I think that it’s not all be supported, if you use influxdb, you could reference influxQL, cast-operations, look at here: