Hosted Grafana: Authorization Failed

I had a previous grafana page that was working fine. This morning however, it appears to have an issue trying to log in. I’m not too sure whats going on here because I don’t have access to any logs. This is the free grafana plan.

Are you able to log in to grafana.com?

Yup, I’m posting here with the same account I had. I -think- this may be an issue with the OAuth client I deleted which may have been default.

If you go to your profile and click the “Log In” button, do you get the same error?

Yes, I get the same error.

I’ll ask the GrafanaCloud team if they can investigate.

@ahanuschak as you’ve discovered if you delete the OAuth client associated with your Grafana instance then the OAuth login won’t work any more :wink: I was able to recreate the OAuth client entry for you, let us know if you are still having problems logging in.

Can you please do the same for me? I’m having the same problem.

@relay you should be all set.

it works :muscle::pray:, thanks!

1 Like

Can you do the same for me please? Thanks in advance!

I don’t think I deleted the oAuth client, but this sounds like what is happening to me also. I am trying out the free account on Grafana Cloud. I started receiving Unauthorized messages in different places in the interface and now I get the attached error when I try to go to my dashboard.

Would you mind checking my account?

Thanks!

Was experiencing a similar problem earlier but instead of that message this one displayed:

login.OAuthLogin(missing saved state)

I am getting the “(missing saved state)” version now too.

It feels like my authorization times out. I can work for a few minutes just fine, then I’ll start getting “Unauthorized” errors while trying to work with a panel. If I try to log into the instance again, I get that login.OAuthLogin error. The timing isn’t consistent, though. It will fail after a couple minutes or 15 minutes. Eventually, I can get back in and work for another few minutes before it all happens again.

Logging out and in and killing all grafana cookies and other data does not solve the problem.

We have the same problem. How can I get a fix in my Hosted Grafana org youmoni

Hi, I have the same problem… Deleted OauthClient and nothing works anymore.
Please fix…