Grafana will not start after install

It pulls the package fine but when starting it errors out

Error: ✗ Get “https://grafana.com/api/plugins/grafana-clock-panel/versions”: context deadline exceeded (Client.Timeout exceeded while awaiting headers)
Error: ✗ Get “https://grafana.com/api/plugins/grafana-clock-panel/versions”: context deadline

When I got to the actual Website I am able to hit it.

In Docker Portainer I get this error"
Stopped for 1 minute with exit code 1

  • Did you follow any online instructions? If so, what is the URL? I checked to see if there was an outage and There is none reported today. There was one yesterday

Are you trying to install Grafana or the clock panel plugin?

I’m having the same issue just after installing the plugin. Any ideas why this is happening ?

Hey @lorry96

Same question: are you trying to install Grafana or the clock panel?

1 Like

hi, i was trying to install plugin. For context, i installed Grafana as docker image and this issue happened. As a workaround , i installed grafana standalone and then installed plugin. It worked like a charm

Hey @lorry96

Can you show how you installed the plugin please?

1 Like

Hi, here is what i used:

Go to : /usr/share/grafana/bin

sudo ./grafana cli plugins install <plugin_id>
Exemple:

Sudo ./grafana cli plugins install marcusolsson-csv-datasource

Which plugin_id did you put?
Also, can you make sure your server have an Internet acces?

Hi, i used csv plugin as plugin_id. With docker image i think the issue was related to proxy / FW rules (i’m in corporate enviornment) . Switching to standalone version solved the issue. I was able to install plugins and grafana started normally. Everything is working right now. Thanks for your help