Grafana Docker Error

Hello guys!
I’m from Brazil and I’m sorry for my English.
I created a container with Grafana in Docker and in the first few days it worked perfectly, but in a few days it has presented me with an error:

Plugin Error
(SystemJS) XHR error (403 Forbidden) loading

Error: XHR error (403 Forbidden) loading

Error loading as “./zabbixCachingProxy.service.js” from 3000 / public / plugins / alexanderzobnin-zabbix-app / datasource-zabbix / zabbix.js

Does anyone know what it is or how to solve it?

Strange. How did you install the Zabbix plugin? Did you use the env variable -e "GF_INSTALL_PLUGINS=... (see here).

Yes, I did like this:

docker run -d --name=grafana --hostname=grafana
-v /etc/timezone:/etc/timezone -v /var/lib/grafana/:/var/lib/grafana/
-e “GF_INSTALL_PLUGINS = foursquare-clouderamanager-datasource”
-e “GF_INSTALL_PLUGINS = grafana-clock-panel, grafana-simple-json-datasource”
-e “GF_INSTALL_PLUGINS = alexanderzobnin-zabbix-app”
-p 3000:3000 grafana/grafana

Delete the /var/lib/grafana directory and re-create it by giving 777 permission.

It sounds like this bug but I’m not sure why you would be seeing it:

Is it only the zabbix plugin that does not work?

Yes, just the Zabbix plugin.
At first everything was OK, this error appeared from a few days to ago. It worked for a month practically.

Have you tried stop/starting the docker container (that does an automatic update if there is a new version). Or even rebuilding the container from scratch:

docker pull grafana/grafana
docker stop grafana 
docker rm grafana

and then your docker run command again.

I managed to find the problem. The Zabbix plugin was being barred by the proxy. I did not quite understand why, but I released his access and it worked again.

Thanks for the help ^^

1 Like