Grafana v6.0 Beta 2 scroll bars

Is it just me, or is anyone else finding navigation difficult with the narrow, hidden scrollbars in v6.0 Beta 2?

It appears that the scrolling is only activated when clicking on a hidden scrollbar hotspot, but especially when editing a panel, it’s not easy to find the hotspot to scroll down and access further options.


Do you have scrollwheel on your mouse or scroll with the touchpad? Is there a reason you want to grab the scrollbar handle? That is usually only relevant for super long pages and you want to quickly go down. The queries and options views are not very long.

what browser version and OS are you on, the scrollbar is always visible if it’s needed for me.

No mouse, I’m using a laptop with a touchpad.

The 15" laptop screen resolution is 1366 x 768, and therefore need to scroll down to access features that are below screen height, such as Min Time Interval, Relative Time etc, in the full screenshot below.

Current version of Google Chrome (Version 72.0.3626.109 (Official Build) (64-bit))
Windows 10 Home.

As you can see from the gif screenshot in the post above, they are hidden until selected.

This is a full screen print -

…and if I click the hidden scrollbar, I’m then able to access the options below -

ok, strange. Not sure why it’s hidden for you. It’s always visible for me. Will text soon on windows, see if I can replicate.

Does your touchpad not have scroll feature / area?

Unfortunately no.
The keyboard has Page Up/Page Down keys, also Up & down arrows, but I have to get the focus of the scroll bar before they operate.

I don’t have this problem with any other website or application (like node-RED dashboards.
Or even v5 of Grafana

Was not aware there existed touchpads without scroll feature, been on every touchpad have ever used last 6 years or so.

I don’t have this problem with any other website or application (like node-RED dashboards.
Or even v5 of Grafana

Well it’s a bug that you cannot see it, it should be visible. Must be somethig with chrome and windows.

It’s not a big problem, I just thought I’d feed it back to make you aware.

We appreciate all of the work that you are putting into v6.00, not long now until launch time…

I’ve just loaded the nightly build Version 6.1.0-e811d1e1pre as I see that you’ve made some scrollbar changes today.

It is much better, and more responsive, but the scroll bars are quite thin (as can be seen from the screenshot above).

It appears that the browser default scrollbar width is being overridden by Grafana??


We are using Grafana on a touch screen. So there is no mouse input, only touching the screen.
And it is almost impossible to catch this thin scrollbar with a finger.
Is there any option that this can be configured somewhere.

Usually, users intuitively trying to scroll panels by dragging in the middle of a panel, like moving the content up, but this ends up with selection of the content (if there is text).
Maybe there is a way to disable text selection within a panel?

I’d appreciate any help.

I am using a trackball with no mousewheel. This is usually no problem, but Grafana makes it especially hard. I would support a profile configuration option, where one could select that scrollbars are wider and don’t hide.

It’s an accessability issue.

1 Like