Grafana Unit for MB/GB etc

Hi,

I have a numeric value in bytes in my postgresql database which I would like to visualize as a time series. However, I cannot find any units for MB/GB etc in my settings. From Googling, I think there should be a ‘Metric’ or ‘IEC’ category with these units.

image

Do I have to do / install anything to enable / use these units?

Best Regards,
Marius

Hi Marius,

Try typing the word data and see if that helps you

1 Like

Hello,

I’ve got a question, which is the same category.
I am currently facing a strange behaviour and cannot seem to find the reason.
My monitor (Icinga) gathers performance data in KB or MB and the conversion to GB is correctly for the performance data part.
When looking at the Grafana data the conversion is off.
For example: one VM is reporting a total memory capacity of 536870912KB which translates to 512GB.
Grafana shows either 536GB using data/bytes(SI) or 500GB using data/bytes(IEC).
Same is for true for disk capacity: 3.16TB (3317092MB) gets shown as 3.32TB in Grafana.

I hope someone can help me find the reason behind this.

Kind regards

Hi @lfrank2021

My first suspicion would be that Grafana may be down sampling the data. If you click on the query editor, then query options, you will be able to see if this is happening or not. Sorry for the screenshot quality, I’m only on my phone.

If this isn’t the case, what visualisation are you using to display the data?

Thank you for the response.

image
The visualization is a Time Series.

Kind regards
Frank

Hmm. When you do not select a standard unit, are you seeing the expected results? What intervals are you receiving the data? And what time range are you looking over?

The only other basic suggestions I can think of is to ensure that you are using the correct selector (e.g max, min, last), disable any downsampling and try using a different visualisation such as table to see if that changes anything.

Sorry I can’t help diagnose your problem. I’m sure someone else on here will be able to answer your query though!