Grafana refuses to display InfluxDB data even though it exists

Hello,

I am trying to display InfluxDB1.7.11 data in Grafana. I have tried Grafana version 4 and 7, data refuses to show up in the graph. Here is a screen shot:

I know there is data in the table though, as if I run the query in influx I see the following:
(I limited by 10 because its too much data and I wanted to show the query)

If I try to trim down grafana with the exact query, I see the attribute appear but no data
What am I missing here? Why will the data not appear in Grafana from influxdb source?

Also, read though all of this → Grafana, influxdb query problem - #23 by guidanzkishore. Tired all recommended, nothing in that post helped.

Ok hold up, I think I know the answer, need to trouble shoot more but the EPOCH time is showing 2020…

The router is showing the same time as well, Let me try to fix that first see if it fixes it. brb.

That was it! I deployed a ubuntu server and install ntp and bind. Then linked the system to it.
I see data now :slight_smile: