Grafana Oncall installation problems

Hi all

Using Grafana v9.2.3 running on Ubuntu 20.04.4 LTS

ImTrying to install Oncall from GitHub - grafana/oncall: Developer-friendly incident response with brilliant Slack integration
but getting errors of cant connect or that the invite token is invalid

heres the log :
logger=licensing t=2022-11-13T04:15:00.950768699Z level=info msg=“Validated license token” appURL=http://localhost:3000/ source=disk status=NotFound
logger=licensing.renewal t=2022-11-13T04:15:00.950920116Z level=warn msg=“failed to load or validate token” err=“license token file not found: /var/lib/grafana/license.jwt”

I checked with ftp and found no JWT file in that folder which i am assuming is my problem , but how do i create it?

Its a new install of grafana on the local VM and also Oncall is installed on the same VM
Everything else seems fine.
Even removed docker and re-installed and ran the install again according to github site but same issue.

Any Ideas?

Thank you

Hi @jaco1234,

Welcome to the :grafana: community support forums !!

Well, I haven’t yet used Oncall but, did you already check the documentation regarding it as it will be a good place to start about its pre-requisites and what are its dependencies and requirements?

I hope this helps.

Hi

Yes i have read that through.
It is installed on a ubuntu server running on VMware .
It is actually my Zabbix server that i have installled Grafana onto, and connected zabbix to pull the metrics which works fine. I just cant however get Oncall Plugin to work.

I get the following error as well when trying to connect the plugin :

logger=context userId=1 orgId=1 uname=admin t=2022-11-14T14:41:05.486426007Z level=info msg=“Request Completed” method=POST path=/api/plugin-proxy/grafana-oncall-app/ap i/internal/v1/plugin/sync status=403 remote_addr=x.x.x.x time_ms=113 duration=113.445954ms size=63 referer=http://x.x.x.x:3000/plugins/grafana-oncall-app handler=/api/plugin-proxy/:pluginId/*

(IP’s hidden)

Tried creating different users and setting that in the docker-compose.yml file , also did not work

and another error also ( taken from Browser Debug) :

  1. Request URL:

http://x.x.x.x:3000/api/plugin-proxy/grafana-oncall-app/api/internal/v1/plugin/sync

  1. Request Method:

POST

  1. Status Code:

403 Forbidden

  1. Remote Address:

x.x.x.x:3000

  1. Referrer Policy:

strict-origin-when-cross-origin

  1. Response HeadersView source

  2. Allow:

GET, POST, HEAD, OPTIONS

  1. Cache-Control:

no-cache

  1. Content-Length:

63

  1. Content-Security-Policy:

sandbox

  1. Content-Type:

application/json

  1. Date:

Mon, 14 Nov 2022 16:14:06 GMT

  1. Expires:

-1

  1. Pragma:

no-cache

  1. Referrer-Policy:

same-origin

  1. Vary:

Origin

  1. X-Content-Type-Options:

nosniff

  1. X-Frame-Options:

deny

  1. X-Xss-Protection:

1; mode=block

  1. Request HeadersView source

  2. Accept:

application/json, text/plain, /

  1. Accept-Encoding:

gzip, deflate

  1. Accept-Language:

en-US,en;q=0.9

  1. Connection:

keep-alive

  1. Content-Length:

0

  1. Cookie:

grafana_session=b277279713fcb39ea2be8b0d4198733e

  1. Host:

x.x.x.x:3000

  1. Origin:

http://x.x.x.x:3000

  1. Referer:

http://x.x.x.x:3000/plugins/grafana-oncall-app?page=configuration

I have changed grafana ports as well as the docker ports from 3000 to something else , and 8080 to something else, thinking it could be my firewall blocking it , but it doesnt.
It does seem that the Oncall Backend is working as i get an “OK” when opening the url in a browser.

I even created a new VM with ubuntu server installed and started everything from scratch on a different machine and then the plugin works, and i have followed the exact same steps.

okay so have reinstalled docker as well as grafana and changed a setting on the .env file to rather point to : echo "DOMAIN=http://IP address:3001 a ip address instead of localhost and now it seems like its authenticating , however now i get the following :

OnCall took too many tries to synchronize. Did you launch Celery workers? Background workers should perform synchronization, not web server.

Hi @jaco1234,

Can you please provide the logs so that we can see more visibility as what happened in the background?

Thanks

Hi

I managed to get it working. I Created a new VM on our server just for grafana, installed ubuntu server and grafana and oncall from scratch and worked first time.
So i think there must have been something weird on the zabbix server causing issues.

Now i just need to figure out how to connect telegram and how to get a telegram_webhook_host as i dont find much documentation on it