Grafana instant query option is returning empty results always

From last few days we are seeing Instant query in Grafana is not working and returning empty results always. This used to work fine earlier.

We enabled Instant query to have accurate results in Stat visualisation. If disabled we are getting incorrect results. We are using below query and visualising results in Stat visualisation.

sum(increase(abc_volume_action_count{kube_cluster_name="$xyz",controller="provision",result="completed"}[$__range]))

  • Grafana v7.5.6
  • Is there a way we can display accurate counter type metrics results without using Instant query ? or
  • Way to fix Instant option is not working ?.

More details here time series - Grafana instant query option is returning empty results - Stack Overflow

Any help ?

Hi @manjunathkallannavar,

Welcome to the :grafana: community support forums !!

I will try to test this out on my test VM.

Did you try to reproduce this on the new Grafana ver 9 as well?

Hi @usmanahmad Thank you. Yes I tried to reproduce in v9 as well. Results are same. Attached screen shot.

Hi @manjunathkallannavar,

Thanks for the reply.

I currently do have a K8s environment or setup to reproduce it. Does it also happens with any standard Prometheus queries e.g. getting any CPU info etc. OR specific for K8s ?

Hi @usmanahmad , Yeah I see issue is reproducible even with standard K8s metrics. If instant is disabled everything works fine.

Hi @manjunathkallannavar,

So I tried to reproduce it on my local machine using the Prometheus Uptime query. I played around with the Instant option but unfortunately not able to reproduce it.

Will it be possible for you to reproduce this on https://play.grafana.com/ and share the result with us?

Incase if it is not possible for you to reproduce there, then I suggest that you increase the log level to DEBUG mode and reproduce this case. So that we can see what logs are telling.

I hope this helps.

Thanks @usmanahmad will give a try.