Grafana-cli: command not found / Cannot Install Plugins

Hey Guys -

I recently discovered Grafana, set it up with a few sources to monitor lab systems & my SCCM lab, and LOVE it! Everything seems to be working great except for one issue I cannot figure out. I tried installing a couple of plugins, however when trying to use grafana-cli from an SSH session; it states “grafana-cli: command not found.” Below is some information about the build plus what I’ve tried to resolve…

Build Details

  • Host: Debian 9.7.0 x64
  • Grafana Version: Grafana v5.4.3 (commit: 6539180) (grafana_5.4.3_amd64.deb)
  • Although familier with Linux, I used these steps to set up Grafana and initial sources. The only exception is that I replaced strings to download and install Grafana with the current Ubuntu & Debian ones from the "Get Grafana" webpage listed below:
  • wget
  • sudo dpkg -i grafana_5.4.3_amd64.deb
  • Datasources: InfluxDB 1.7.3 (Installed on same server as Grafana) & Microsoft SQL Server
  • Populators: Telegraf 1.9.3 for Windows & OhmGraphite for Windows (Open Hardware Monitor stats)

What I’ve Tried So Far

  • Executing Directly: Thinking the path may just not be set, I found that “grafana-cli” was located in “/usr/sbin” so CD’d to the path and executed it, but still got message that it wasn’t found. I checked the permissions for “grafana-cli” in that path which were 755
  • Browsing to "/var/lib/grafana/plugins" I can CD to "/var/lib/grafana", but although my user is in the sudo group, I get Permission Denied when trying to CD or browse via SCP to "/plugins"

I’m happy to submit any files or logs and would have done so in this case, but didn’t think any were relevant since the error isn’t in Grafana specifically. I posted this as an issue in Grafana’s GitHub Repo as it does seem to be such, but wanted to post here also in case anyone else had encountered.

Anything you can suggest to resolve would be fantastic - Thank You!