[Firefox] Grafana dashboards causes browser to load page infinitely

  • What Grafana version and what operating system are you using?
    Grafana v10.0.3 (eb8dd72637) / Gentoo GNU/Linux
  • What are you trying to achieve?
    View my dashboard
  • How are you trying to achieve it?
    … within Firefox
  • What happened?
    100% CPU load and grafana page hanged
  • What did you expect to happen?
    Normal functioning as in Chromium
  • Can you copy/paste the configuration(s) that you are having problems with?
  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.
    Can’t open DevTools within the impacted tab
  • Did you follow any online instructions? If so, what is the URL?
Screenshots from Firefox & Chromium

Firefox, tab hanged:

Chromium, everything OK:

Remove some panels in Chrome and then test it in Firefox - you will identify which panel is causing a problem, so you can focus on that one. Also make sure you have proper time aggregation in your queries - it doesn’t make sense to have 1 min aggregation or raw data for last month period.

I have hided all panels to a rows, page loaded immediately.

I have tested Gauge - when displaying it, Firefox works fine. However I have opened “state timeline” panel and it caused browser hung. This behaviour is happening with “time series” as well.

As I can see, for 30days the Interval is set to 1h, so the issue is certainly not in this.

Furthermore, some time ago Firefox worked fine for the same dashboards, but currently it does not for some reason.

I have tried to open this dashboard with 5 minute time range and it lagged only for 5-10 seconds (100% CPU load + Firefox alert “this page is slowing down Firefox”), however graph was not shown for some reason.


P.S. Exactly the same behaviour is observed from clear Firefox Profile without custom settings / about:config changes / plugins.

I do have exactly the same problem… Is very annoying.

  • Grafana is installed on a raspberry pi4 8GB on Raspbian bullseye Version 10.0.3
  • My two devices are a beefy PC and an old Lenovo T450s, both running Gentoo
  • months ago laptop still worked fine but PC stalled like above mentioned. Nowadays both machines hang when displaying Grafana
  • Using Chromium, all works fine

sorry this thread is in German:

it is referencing to the language setting, I also tried, but mine are fine, so this was not it…

I have managed to fix my issue by installing Librewolf (mine is 116.0.3-1). Probably there is something wrong with Firefox ESR (mine installed firefox with the bug is 102.14.0esr)

same firefox version here, but just now an update is comming to 102.15.0 but I do have the trouble since some time so I doubt, that will do the trick…

LibreWolf It is not part of the gentoo portage system, so a manual installation outside the package manager would be needed…

If librewolf solved it, that means some of the USE flags might be responsible

I had no luck with USE flags, however you actually can install librewolf using portage, check out official wiki page: LibreWolf - Gentoo Wiki

yet it would be nice, this firefox issue getting solved. I even ased on IRC channel but no luck there either. If I have the patience some guys at #pixls.us are capable grafana users and wanna evaluate thru dockers, but I need time to got that route…


I did build librewolf with USE flags like this www-client/librewolf X clang dbus hwaccel and it behaved as my firefox. it stalled. Then removed this and it works. So I will now adjust my firefox accordingly and check it out. Might it be clang… we will see…

over night my old T450s built Firefox 117.0 incl. useflag hwaccel and I installed media-libs/nvidia-vaapi-driver.
It works all fine now, Grafana is shown well as expected

I have the following USE flags:

[ebuild   R    ] www-client/firefox-102.15.0:esr::gentoo  USE="dbus eme-free geckodriver gmp-autoupdate hardened hwaccel lto openh264 pgo pulseaudio system-av1 system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-png system-webp -clang -debug -jack -libproxy -screencast (-selinux) -sndio (-system-python-libs) -wayland -wifi" L10N="-ach -af -an -ar -ast -az -be -bg -bn -br -bs -ca -ca-valencia -cak -cs -cy -da -de -dsb -el -en-CA -en-GB -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -ia -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mk -mr -ms -my -nb -ne -nl -nn -oc -pa -pl -pt-BR -pt-PT -rm -ro -ru -sco -si -sk -sl -son -sq -sr -sv -szl -ta -te -th -tl -tr -trs -uk -ur -uz -vi -xh -zh-CN -zh-TW" 0 KiB
[ebuild   R   ~] www-client/librewolf-116.0.3_p1:0/116::librewolf  USE="X dbus eme-free gmp-autoupdate hardened hwaccel jumbo-build lto openh264 pgo pulseaudio system-av1 system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-png system-webp -clang -debug -geckodriver -jack -libproxy -screencast (-selinux) -sndio (-system-python-libs) -telemetry -valgrind -wayland -wifi" L10N="-ach -af -an -ar -ast -az -be -bg -bn -br -bs -ca -ca-valencia -cak -cs -cy -da -de -dsb -el -en-CA -en-GB -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fur -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -ia -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mk -mr -ms -my -nb -ne -nl -nn -oc -pa -pl -pt-BR -pt-PT -rm -ro -ru -sc -sco -si -sk -sl -son -sq -sr -sv -szl -ta -te -th -tl -tr -trs -uk -ur -uz -vi -xh -zh-CN -zh-TW" 0 KiB

However only librewolf works properly. I do not have nvidia thus I do not need media-libs/nvidia-vaapi-driver