Field Override STRING is not available

I have a Table panel, table not time series, and a column contains deveui in hexidecimal.
I need to create an override for this field to display it as a string, for example 88e824.
Grafana 7.0 is displaying this as infinity. Other deveui’s are formatted as scientific notation.

Any ideas on how to force this as a string?

I have tried the method below, but the ‘string’ option is not displayed when creating override.


This is something that has been introduced in Grafana 7.2.0 that is still in beta so it’s not available in the last stable release. You can either try the beta or wait for the 7.2.0 to be officially release to use this option.