/etc/grafana/grafana.ini ignored


I’m new to Grafana. I have a Debian 10 VM and I installed Grafana from APT repo. I have a simple problem.
/etc/grafana/grafana.ini is just… ignored.

The first try was about changing sqlite3 to mysql (mariadb). I saw it was not working so I tried something simple, changing:

The http port to use

;http_port = 3000


The http port to use

;http_port = 3250

But the web server still respond to port 3000 and socket is binded to it

mag 28 13:20:29 maz-v267-test grafana-server[3404]: t=2020-05-28T13:20:29+0200 lvl=info msg=“HTTP Server Listen” logger=http.server address=[::]:3000 protocol=http subUrl= socket=

Then i moved /etc/grafana/grafana.ini to /etc/grafana/grafana.bak, leaving no grafana.ini behind… process fails upon restart. so It’s not completely “ignored” but what’s inside is not effective.

Can you help me?? thanks!

Lines starting with semi-colon ; are comments (and the default value) and are not being read by Grafana.

If you want to change any settings you need to delete the semi-colon.

1 Like

Semi-colon means “comment” (in other words, ignore).

Remove the semi-colon so that the line reads purely “http_port = 3250” and
then restart Grafana.


1 Like