Change Default Port

Hi, i want to change the default port from 3000 to 9152 now what exactlly i have to do.

Hi @riponmollick66

Open your .ini file with a text editor. Find the section mentioning the HTTP port to use. Semicolons (the ; char) are the standard way to comment out lines in a .ini file. If you want to change a setting, you must delete the semicolon ( ; ) in front of the setting before it will work.


# The HTTP port  to use
;http_port = 3000

A common problem is forgetting to uncomment a line in the custom.ini (or grafana.ini ) file which causes the configuration option to be ignored.

Thanks so much for your time and help. It’s working. Actually i forgot to uncomment in the grafana.ini file…Thanks again

1 Like