Error "User could not be found"


#1

I created a initial instance for small teams and want to add a user. But I keep being told “User could not be found” whenever I try and add users by either email or username. I’ve created another Grafana account to test but I get the same error. Am I misunderstanding how the process works or what my Small team is entitled to?
grafana-user-not-found


#2

Sorry, missed this question. Did you figure it out? You can see the number of users in your plan on Grafana.com under settings for your Hosted Grafana instance:

image


#3

Yes I was resolved for me by one of the Grafana team (Matt). Apparently my organisation was not correctly set up. Once they did whatever they did, I was able to to find and add users.


#4

Hey guys, how did you get the Grafana team to fix this? There is no support other than purchased, I cannot add any users and we have the $90/monht plan which comes with some basic support but no idea how to access that. I sent an message to sales to see if I get a response since I see the response here took over a month. Just a bit frustrated by the whole thing. Any help would be welcome. Thanks!


#5

I think (it was a while ago now) I sent an email to hello at grafana dot com. Whatever the problem was, it couldn’t be fixed in the UI, it required some change at their end to alter out organisation setup. Unfortunately I didn’t get any details.


#6

Users are added via Grafana.com by adding them to your organization there.

Are did this not work?


#7

Daniellee, yes I see that as well, but when I go to grafana.com it doesn’t
let me add any users. I’m like in a vicious cycle. How do I get the people
a grafana.com to help me with this?


#8

When you go to the members section of your org, does it look like this - with an Add Member button:

Or are you getting an error?


#9

Thanks Danielle for your response.

When I go to grafana.com to add members I get this error code “not found”


#10

It doesn’t seem like that user is registered? The user management is still very basic so that user has to register themselves first before they can be added. There is no invite function yet.


#11

That’s exactly what was happening to me. Have you emailed hello@grafana.com? They will fix this for you.