Environment variables doesn't work at all. help me plz

Hola there.
I’m trying to configure my grafana server by environment variables.
For some reason, it doesn’t work at all. (for any configuration)

Using latest build 4.4.3 on ubuntu 14.04
Before starting the service: (service grafana-server start)

export GF_SECURITY_ADMIN_PASSWORD=kuku
export GF_SERVER_HTTP_PORT=1337
service grafana-server start

t=2017-09-03T15:12:13+0300 lvl=info msg=“Starting Grafana” logger=main version=4.4.3 commit=54c79c5 compiled=2017-08-07T11:50:18+0300
t=2017-09-03T15:12:13+0300 lvl=info msg=“Config loaded from” logger=settings file=/usr/share/grafana/conf/defaults.ini
t=2017-09-03T15:12:13+0300 lvl=info msg=“Config loaded from” logger=settings file=/etc/grafana/grafana.ini
t=2017-09-03T15:12:13+0300 lvl=info msg=“Config overridden from command line” logger=settings arg="default.paths.data=/var/lib/grafana"
t=2017-09-03T15:12:13+0300 lvl=info msg=“Config overridden from command line” logger=settings arg="default.paths.logs=/var/log/grafana"
t=2017-09-03T15:12:13+0300 lvl=info msg=“Config overridden from command line” logger=settings arg="default.paths.plugins=/var/lib/grafana/plugins"
t=2017-09-03T15:12:13+0300 lvl=info msg=“Path Home” logger=settings path=/usr/share/grafana
t=2017-09-03T15:12:13+0300 lvl=info msg=“Path Data” logger=settings path=/var/lib/grafana
t=2017-09-03T15:12:13+0300 lvl=info msg=“Path Logs” logger=settings path=/var/log/grafana
t=2017-09-03T15:12:13+0300 lvl=info msg=“Path Plugins” logger=settings path=/var/lib/grafana/plugins
t=2017-09-03T15:12:13+0300 lvl=info msg=“Initializing DB” logger=sqlstore dbtype=sqlite3
t=2017-09-03T15:12:13+0300 lvl=info msg=“Starting DB migration” logger=migrator
t=2017-09-03T15:12:13+0300 lvl=info msg=“Executing migration” logger=migrator id="copy data account to org"
t=2017-09-03T15:12:13+0300 lvl=info msg=“Skipping migration condition not fulfilled” logger=migrator id="copy data account to org"
t=2017-09-03T15:12:13+0300 lvl=info msg=“Executing migration” logger=migrator id="copy data account_user to org_user"
t=2017-09-03T15:12:13+0300 lvl=info msg=“Skipping migration condition not fulfilled” logger=migrator id="copy data account_user to org_user"
t=2017-09-03T15:12:13+0300 lvl=info msg=“Starting plugin search” logger=plugins
t=2017-09-03T15:12:13+0300 lvl=info msg=“Initializing Alerting” logger=alerting.engine
t=2017-09-03T15:12:13+0300 lvl=info msg=“Initializing CleanUpService” logger=cleanup
t=2017-09-03T15:12:13+0300 lvl=info msg="Initializing Stream Manager"
t=2017-09-03T15:12:13+0300 lvl=info msg=“Initializing HTTP Server” logger=http.server address=0.0.0.0:3000 protocol=http subUrl= socket=

The default password is still admin and the default port is still 3000.

What did i do wrong?

  1. The syntax looks correct and I tested running:

    and I got this in my logs:

    INFO[09-04|08:54:29] Config overridden from Environment variable logger=settings var="GF_SERVER_HTTP_PORT=1337"

    Just as a sanity check, can you check that they are set with this command:

    echo $GF_SERVER_HTTP_PORT

  2. As a sidenote, the first variable (GF_SECURITY_ADMIN_PASSWORD) you are trying to set will not work even if you solve your issue with environmental variables. From the docs:

    The password of the default Grafana admin. Set once on first-run. Defaults to admin.

    It will only work the first time you start the Grafana server.