Elastic datasource time stamp in Grafana


I am new to Grafana.

I have configured a datasource to connect to elastic index. The data in the index is stored in UTC by default.

When I try to view that data on a Kiabana Dashboard, it automatically converts the data into my browser time.

However, when I tried doing the same in Grafana, it does not convert. The data is always displayed only in UTC.

The data which is displayed on the Grafana dashboard needs to be on the browser time.

I tried to change the settings from the dashboard settings but no luck.

Any suggestions on this ?

Weird. If Grafana is not respecting the Dashboard time range settings, that’s probably a bug. If you are not using the most current version of Grafana, try upgrading. If the problem persists, please file a bug report.