Dynatrace Plugin Unable to load cache After Changing API Token in Data Source settings

As the title says, I had to generate a new Dynatrace API Token and, when I updated the Dynatrace Data Source with the new token, it seems to have broken the Dynatrace plugin completely.

All of my already constructed charts no longer show data and when I try and run a query (in Explore or when configuring a panel) I get the error Unable to load cache that shows up in the top right-hand corner of Grafana.

What’s really weird and very frustrating is that I’ve tried deleting and re-adding the Dynatrace Data Source. I’ve tried completely uninstalling the Dynatrace plugin and re-installing it (making sure to restart the Grafana service before/after as needed of course), and I’ve even reinstalled Grafana completely (making sure to delete the Grafana.db so that it gets rebuilt with new data), as well as just doing a reboot of the server itself.

No matter what I do, I get that error. I don’t even understand why it’s saying Unable to load cache considering I never turned the Dynatrace Data Source’s Cache feature on (although I did also try turning it on, clearing the cache, and turning it back off again, but that didn’t work either.).

I’ve verified that the new API key works fine by installing and running Postman on the Grafana server and, using the API key, was able to successfully make calls and receive data from my Dynatrace instance. I am truly baffled how it absolutely will not work now. The API key has the exact same permissions as it did before (Read Entities, Read Metrics, and Read Problems). Unfortunately I couldn’t revert back to the old key because it had to be deleted, but the new key works and is exactly the same. Plus, if the key was the problem, I’d be getting a different error.

Our Grafana rep I was talking with mentioned that he thinks some other customers have complained about something similar, so I was hoping maybe someone on here ran into this and figured out a way to fix it, because at this point I am completely stumped…

If I use Code instead of Builder and put a known working metric in, I get this error:
error loading cache: json: cannot unmarshal number 50.0 into Go struct field MetricDefaultAggregation.metrics.defaultAggregation.parameter of type int

Everything was working completely fine before I changed the API key…

  • Grafana Enterprise 8.5.1 (Dynatrace Plugin 3.4.1)
  • Self-Hosted on Windows Server 2019 Datacenter
  • Not using any alerting right now, just trying to configure dashboards for a POC of this product

You have paid Grafana version, so it better for you to contact your Grafana support.

Well, we’re just doing a POC with a trial license, so we’re not really licensed. Was just hoping some people in the forum may have seen this as well and could share what they may have done to fix the issue.

You can’t fix Golang issues. Dynatrace plugin source code is not open sourced, so only Grafana devs can help.
Generic recommendation - test it on the linux machine and/or use older plugin version (e. g. 0.9.4 which is using older Dynatrace API version).

According to our Grafana sales rep, there is a new version they have internally that fixes the issue and should be available soon, hopefully. They have to run it through internal QA first. Just stinks because about 2 days of our limited trial have been wasted already trying to fix this issue. But I’m glad they’re at least fixing it soon, hopefully…