Datasource "Max series" value never reached

[Tested in Grafana 7.5.0 and 9.2.2]

I am trying to restrict a little bit the amount of information retrieved from our InfluxDB datasources in user-defined dashboards. I found that the parameter “Max series” can be useful to limit the number of series processed by Grafana.

So, test it I set a very low value (1 or 2 series) and try to force the limit a dashboard retrieving a huge number of series.

I expected to get the message that the result has been truncated due to the series limit, but this is never shown and the dashboard aparently process all the series.

Is there any additional setting to be configured in order to apply the series limit?

Thank you,

Hi @gelofr9 and welcome to the forum.

I read this and compared with your post above. Sounds like you did everything correctly. Did you restart your container environment and/or InfluxDB and/or Grafana?

Hi Grant, thanks for your reply.

Yes, that is indeed a parameter to take into consideration, but that is for setting the limit on InfluxDB side. I was interested to restrict it from Grafana side (plus it gives you the advantage that it displays a more understandable message to the end user since it indicates that the limit has been reached in the UI).

I didn’t restart Grafana pod itself, but I tried creating the datasource from scratch. The DS is working excepting the limit.

I will try restarting the Grafana instance, but it should not affect… Any other clue?