Dashboard return "414 Request URI Too Large" when variables is too many

  • What Grafana version and what operating system are you using?
    grafana v7.3.5

  • What are you trying to achieve?

  • How are you trying to achieve it?

  • What happened?
    many options for a variable, i choose “All”, dashboard return “414 Request URI Too Large”

  • What did you expect to happen?
    dashboard display information for all options
    why not use “.*” when i choose “All” in url?

  • Can you copy/paste the configuration(s) that you are having problems with?

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.
    “414 Request URI Too Large”

  • Did you follow any online instructions? If so, what is the URL?

hello i think this is explicit, since grafana variable is URL parameter, if you have a long list of item it could be too long for URL prerequesite.
You may have to create variable to use it as you suggested (use wildcard ).
Maybe you can create hadock solution null by default and have a “all” label choice inserting the right value (OR colum.name like %)

1 Like

Hi @jiahuizhao11,

Welcome to the :grafana: community forum !!

You can also do the following i.e. on the web server e.g. Nginx add the following parameter

client_header_buffer_size 512k;
large_client_header_buffers 4 512k;

Also, one other solution is to use the POST method for HTTP Requests. You will find this setting inside the datasource you configured before creating the query