CSV as DataSource

Yeah still seeing it and have opened an issue. Thanks :slight_smile:

Gather the latest updated and its working fine now :slight_smile:

Thanks again for quicker turnaround :heart_eyes: :love_you_gesture: :clap:

Hi @paveldanilin,

First of all, thanks a lot for developing the plugin and sharing it.

I am facing a similar challenge of using a CSV datasource for time series analysis with grafana and came across the plugin which you’ve developed.

Please find below the screenshot and actual file which I used for plotting the data.

Example CSV

The data is a obtained from a car simulator game (Torcs), and consists of Time Vs Speed / Steering angle etc during a race. The time is negative during the countdown of the race and positive from the start of the race.

I am able to add the csv as a data source and when I click ‘Save & Test’, I am getting an acknowledgement ‘Data source is working’.

But when I start the dashboard, I am not able to visualize any time. I think I am doing something wrong with selection of time axis.
In one of the posts I also read that the columns will be auto-detected. It was also not working for me.

Could you please help me in finding out the issue with this.

Thank you

Hi!
Looks like a problem with data types conversion.
Could you create an issue at repo https://github.com/paveldanilin/grafana-csv-plugin ?

Hi Pavel,

Thanks a lot for the quick reply.
I’ve created an issue titled ’ Csv datatype conversion issue’ in the above mentioned repo.

Thank you for your time

Regards,
Harish

1 Like

Hi Pavel,

Thanks for developing this awesome plugin!
I tried both SacramentocrimeJanuary2006.csv and SalesJan2009.csv as local DS with Grafana v7.3.0 but got error ‘Query failed: near “-”: syntax error’. I think it doesn’t like the ‘-’ in latitude,longitude.

Regards,
Van

Hi @paveldanilin,

With the new version of grafana, we have to sign the plugins, otherwise, the plugins are disabled and not shown in the Datasource list, Now i am using development mode to allow all unsigned plugins, but it would be nice if the plugin you developed get signed offically, so people could use it without problem.

Thanks for the nice plugin,
Ying

@yingwang Hi!

Noted!

I suppose you can use the following configuration parameter:

If I am not mistaken currently there is no way to make the custom plugin signed. Only official plugins are signed.
Thus the solution here is to use the configuration parameter: allow_loading_unsigned_plugins

Let me know if I am wrong.