Correctly recognize special date format in table

Good day

I am using an Ubuntu Server 22.04.2 LTS and the Grafana version is v9.3.6. I use Grafana in combination with InfluxDB2.
In a dashboard I use a table and in it I have a column with a timestamp. Unfortunately I don’t have a usual date or timestamp format. How can I still sort correctly by date and get Grafana to recognize this timestamp in this dashboard?
The date has the following format:
21-02-2023 23:16:14.343265955
DD-MM-YYY HH:MM:SS.---------

Thanks for your help


So are you saying it currently is not sorting properly for you?

What happens?

Good day

Unfortunately not. See screenshot.
Can I specify the format manually in Grafana?

Hi @ffarkas,

Welcome to the :grafana: community support forums !!

We are excited that you joined our OSS community. Please read about some of the FAQs in the community :slight_smile:

You can use the Override function to convert the date to YYY-MM-DD Format

I attached a screencast (open it in a new window as will be easier to zoom in and view more clearly)

timestamp-overwrite 2022-09-26 11-46

I hope this helps.

Hello @usman.ahmad

Thank you very much for your answer. Unfortunately I can’t get it to work with:


The format in the database is: 31-01-2023 11:22:46.335538808 and apparently it is not recognized by Grafana.
However, I need DD.MM.YY HH:MM:SS displayed in the table.

Do you have an idea how I can correct this? Is it possible in Grafana or do I have to adjust my InfluxDB query?

Thank you very much for your help.

In the same override instead of hardcoding it, have also look into this “Date & Time” option.

Its hard to share it as screenshot but it will be under Standard Option → Unit and then select Date & Time and try out each of them if that matches your requirement.

Let us know if this helps.