Container using Image with Grafana-Influxdb-Telegraf not working as expected on 64bit Raspberry Pi OS

A while ago I forked a repository which creates an image with Grafana, InfluxDb and Telegraf to use on my raspberry pi. As it was over 3 years without maintenance it had ancient versions of all software and managed to get it working with the most recent versions of the software (well except Influxdb as the most recent version requires 64bit OS) on the 32bit Raspberry Pi. Ran like a charm.
Then I read that 64bit Raspberry Pi OS is officially out, so installed on my SD-card a new image. Copied the contents under /var/lib/docker from my SSD to the SD and was able to start the whole bunch. Almost all containers seemed to work fine except for the pihole and the one with Grafana. Pihole was easily solved by just upgrading to a 64bit image.
Note that all (other) containers were running the 32bit images.
Influxdb and Telegraf start nicely but Grafana failed to start. It continously complains about
Init Failed: Could not find config defaults. Manually telling that it should use the expected config file and homepath doesn’t give a better result.
Also compiled a 64bit-image with the same result, so finally have to revert back to the 32bit OS.

docker run-command is:

docker run -d
–name influxdb-grafana
-p 3003:3003
-p 3004:8083
-p 8086:8086
-p 22022:22
-v influxdb_data:/var/lib/influxdb
-v influxdb_log:/var/log/influxdb
-v grafana_data:/var/lib/grafana
-v grafana_log:/var/log/grafana
-v telegraf_log:/var/log/telegraf
-e “TZ=Europe/Amsterdam”

The build of the image can be found on and on github.

Any clues what might go wrong?

Solution was easier than I could think of:

after coping /var/lib/docker/* from ssd to /var/lib/docker/* on sd all files where from root and Grafana wants files as grafana as owner. After changing that it now works like a charm.